请选择 进入手机版 | 继续访问电脑版
阳光沙滩博客现金打赏设置邀请好友最新视频下载
+发表新主题
辉辉22222 发布于2018-6-9 15:47 585 次浏览 28 位用户参与讨论
跳转到指定楼层
本帖的地址:https://bbs.sunofbeaches.com/thread-6321-1-1.html
版权声明:本文为作者所有,未经作者允许不得转载--->温馨提示:请加上原文地址!
今天加载一个项目,出现这个报错,但我app里面gradle配置的信息如下(大部分我都给了,只有一点点涉及隐私的没给出来):我上网查了根本就不是那个问题,请问大神这是咋回事,

apply plugin: 'com.android.application'
apply plugin: 'realm-android'
buildscript {
    repositories {
        jcenter()
    }
    dependencies {
        //classpath 'me.tatarka:gradle-retrolambda:3.2.5'
    }
}compileOptions {
        sourceCompatibility JavaVersion.VERSION_1_8
        targetCompatibility JavaVersion.VERSION_1_8
    }
    compileSdkVersion 27
    buildToolsVersion "27.0.3"
    defaultConfig {
        applicationId "cn.com.happyever.hephone"
        minSdkVersion 15
        targetSdkVersion 27
        versionCode 30
        versionName "1.0"
        testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"

        ndk {
            //选择要添加的对应cpu类型的.so库。添加64位得库会与realm 冲突。
            abiFilters 'armeabi', 'armeabi-v7a'
        }

        manifestPlaceholders = [
                JPUSH_PKGNAME: applicationId,
                JPUSH_APPKEY : "ab4a7b959bff9211d02d42a6", //JPush上注册的包名对应的appkey.
                JPUSH_CHANNEL: "developer-default", //暂时填写默认值即可.
        ]
    }
    buildTypes {
        release {
/*            ndk {
                abiFilters = ["armeabi", "ameabi-v7a"]
            }*/
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
        debug {/*
            ndk {
                abiFilters = ["armeabi", "ameabi-v7a"]
            }*/
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
            signingConfig signingConfigs.release
        }
    }
    sourceSets {
        main {
            jniLibs.srcDirs = ['libs']
        }
    }
    packagingOptions {
        exclude "lib/arm64-v8a/librealm-jni.so"
        exclude "lib/armeabi/librealm-jni.so"
    }
}

dependencies {
    implementation 'com.jakewharton:butterknife:8.6.0'
    annotationProcessor 'com.jakewharton:butterknife-compiler:8.6.0'
    compile 'com.google.dagger:dagger:2.12'
    annotationProcessor 'com.google.dagger:dagger-compiler:2.7'
    compile fileTree(include: ['*.jar'], dir: 'libs')
    androidTestCompile('com.android.support.test.espresso:espresso-core:2.2.2', {
        exclude group: 'com.android.support', module: 'support-annotations'
    })
    compile 'com.android.support:appcompat-v7:+'
    compile 'com.android.support.constraint:constraint-layout:1.0.2'
    compile 'com.jakewharton:butterknife:7.0.1'
    compile 'io.reactivex:rxjava:1.1.0'
    compile 'io.reactivex:rxandroid:1.1.0'
    compile 'com.squareup.retrofit2:retrofit:2.0.0-beta4'
    compile 'com.squareup.retrofit2:converter-gson:2.0.0-beta4'
    compile 'com.squareup.retrofit2:adapter-rxjava:2.0.0-beta4'
    compile 'com.google.code.gson:gson:2.8.0'
    compile 'com.android.support:design:+'
    testCompile 'junit:junit:4.12'
    compile 'cn.jiguang.sdk:jpush:3.0.3'
    // 此处以JPush 3.0.3 版本为例。
    compile 'cn.jiguang.sdk:jcore:1.1.1'
    // 此处以JCore 1.1.1 版本为例。
    compile 'com.huawei.android.hms:push:2.5.2.300'
    compile 'com.android.support:multidex:1.0.1'

}

UAN{Z3T1KJOXA}GS(8QLR~7.png

转载请说明出处,本文地址:https://bbs.sunofbeaches.com/thread-6321-1-1.html
【大家可以通过搜索让相关资源!】【有疑问可以到提问模块提问哦!】【如果我去有资源也希望可以分享】【谢谢大家!by bbs.sunofbeaches.com】
回复

使用道具 举报

已有28人评论

黄永康 发表于 2018-6-9 19:35:33
上面不是告诉你做法了吗?[捂脸]


android-apt插件不兼容android gradle插件,请使用annotationProcessor配置来代替。
你看看你那里使用了apt的插件?然后改成annotationProcessor
黄永康 发表于 2018-6-9 19:46:41
表扬,会贴东西上来,代码可以整理一下,太丑了。还有就是不要把密钥和key给出来呢。
黄永康 发表于 2018-6-9 19:48:07
黄永康 发表于 2018-6-9 19:57:48
Snip20180609_7.png
黄永康 发表于 2018-6-9 19:58:50
https://bitbucket.org/hvisser/android-apt/wiki/Migration

这个,你的英文应该可以的,看完就应该解决了。
黄永康 发表于 2018-6-9 19:58:50
https://bitbucket.org/hvisser/android-apt/wiki/Migration

这个,你的英文应该可以的,看完就应该解决了。
辉辉22222 发表于 2018-6-9 20:46:56
但是我全部都看了,根本没有apt
黄永康 发表于 2018-6-9 23:19:57
辉辉22222 发表于 2018-6-9 20:46
但是我全部都看了,根本没有apt

那你现在的gradle版本是多少?
辉辉22222 发表于 2018-6-10 09:58:23
gradle4.1的版本,我的问题主要是出错的那个地方,点进去是app里面的build.gradle文件有问题,但是我贴出去的代码基本就是我整个build.gradle里面的内容了,我也看了一些配置文件,还是找不到网上说的那个apt的问题
123下一页

本版积分规则

关闭

站长推荐上一条 /1 下一条

QQ| 《网站免责声明》|小黑屋| 阳光沙滩(sunofbeaches.com)  

Copyright © 2001-2013 Comsenz Inc.   All Rights Reserved.

Powered by Discuz! X3.2( 粤ICP备14093694号 )

快速
回复
返回
列表
返回
顶部